Cisco HWIC-3G-GSM Config

This is a quick blog about my Cisco HWIC-3G-GSM module which I purchased recently and the steps to install one.
The Cisco HWIC-3G-GSM module is a quick way to setup remote sites with Internet or WAN services and/or useful for backup link solutions for existing cabled sites.

The HWIC-3G-GSM module supports the following service’s:
•General Packet Radio Services (GPRS)
•Enhanced Data Rates for GSM Evolution (EDGE)
•Universal Mobile Telecommunication System (UMTS)
•High-Speed Downlink Packet Access (HSDPA)
 
It supports multiple bands on the multiple services for use in different parts of the world:
•850/900/1800/1900 MHz for GPRS and EDGE services
•850/1900/2100 MHz for UMTS and HSDPA services
 
Routers which support the HWIC-3G-GSM module are the Cisco 1841, 2800 series and 3800 series etc 
Minimum IOS version required is 12.4(15)T1 or above. For this example I'm using c1841-advipservicesk9-mz.124-24.T6.bin IOS.
 

Hardware:

The hardware requirements for the install are easy.
Firstly insert the SIM card into the SIM card holder on the HWIC-3G-GSM card and lock the SIM card in again with the bracket and screw.
Secondly insert the card into a spare HWIC slot on the router and tighten the screws. It's best to use the lowest numbered spare slot first.
Thirdly attach the Aerial
 
Run a show version to check the IOS requirements and most importantly the card is recognised. See output below:
 
Cisco 1841 (revision 4.1) with 355328K/37888K bytes of memory.
Processor board ID FHK00000000
2 FastEthernet interfaces
1 terminal line
1 Virtual Private Network (VPN) Module
1 Cellular interface
DRAM configuration is 64 bits wide with parity disabled.
191K bytes of NVRAM.
62720K bytes of ATA CompactFlash (Read/Write)
 

 

Configuration:

The Sierra Wireless 3G modem on the HWIC card needs to have your 3G provider's APN settings configured. These settings are directly written onto the HWIC card so if you erase the startup-config these APN's will not be lost.

In Enable Mode: (Hardware Configuration)

Below is a list of New Zealand's most common providers. To make it easy I configured all New Zealand's APN's onto different profiles onto the card.

Telecom APN's:
cellular 0/0/0 gsm profile create 1 internet.telecom.co.nz
cellular 0/0/0 gsm profile create 2 direct.telecom.co.nz
Skinny APN:
cellular 0/0/0 gsm profile create 3 wapaccess.co.nz
2degrees APN:
cellular 0/0/0 gsm profile create 4 internet
Vodafone APN's:
cellular 0/0/0 gsm profile create 5 www.vodafone.net.nz
cellular 0/0/0 gsm profile create 6 direct.vodafone.net.nz
cellular 0/0/0 gsm profile create 7 opt.vodafone.net.nz
 
Output will be similar to below:

C1841#cellular 0/0/0 gsm profile create 1 internet.telecom.co.nz
Profile 1 will be created with the following values:
APN = internet.telecom.co.nz
Are you sure? [confirm]
Profile 1 written to modem
C1841#cellular 0/0/0 gsm profile create 2 direct.telecom.co.nz
Profile 2 will be created with the following values:
APN = direct.telecom.co.nz
Are you sure? [confirm]
Profile 2 written to modem
C1841#

 

Most public APN's do not have password requirements. If they do please follow the below commands:

PAP:

C1841#cellular 0/0/0 gsm profile create 15 someapn.someprovider.co.nz pap SOMEUSERNAME SOMEPASSWORD
Profile 15 will be created with the following values:
APN = someapn.someprovider.co.nz
Authenticaton = PAP
Username = SOMEUSERNAME
Password = SOMEPASSWORD
Are you sure? [confirm]
Profile 15 written to modem
C1841#

CHAP:

C1841#cellular 0/0/0 gsm profile create 16 someapn.someprovider.co.nz chap SOMEUSERNAME SOMEPASSWORD
Profile 16 will be created with the following values:
APN = someapn.someprovider.co.nz
Authenticaton = CHAP
Username = SOMEUSERNAME
Password = SOMEPASSWORD
Are you sure? [confirm]
Profile 16 written to modem
C1841#

 

To confirm the profiles have been applied correctly run show cellular 0/0/0 profile and check the output is similar to below.
C1841#show cellular 0/0/0 profile
Profile 1 = ACTIVE*
--------
PDP Type = IPv4
PDP address = 115.189.xxx.xxx
Access Point Name (APN) = internet.telecom.co.nz
Authentication = None
Username: , Password:

Profile 2 = INACTIVE
--------
PDP Type = IPv4
Access Point Name (APN) = direct.telecom.co.nz
Authentication = None
Username: , Password:

Profile 3 = INACTIVE
--------
PDP Type = IPv4
Access Point Name (APN) = wapaccess.co.nz
Authentication = None
Username: , Password:

Profile 4 = INACTIVE
--------
PDP Type = IPv4
Access Point Name (APN) = internet
Authentication = None
Username: , Password:

Profile 5 = INACTIVE
--------
PDP Type = IPv4
Access Point Name (APN) = www.vodafone.net.nz
Authentication = None
Username: , Password:

Profile 6 = INACTIVE
--------
PDP Type = IPv4
Access Point Name (APN) = direct.vodafone.net.nz
Authentication = None
Username: , Password:

Profile 7 = INACTIVE
--------
PDP Type = IPv4
Access Point Name (APN) = opt.vodafone.net.nz
Authentication = None
Username: , Password:

Profile 16 = INACTIVE
--------
PDP Type = IPv4
Access Point Name (APN) =
Authentication = None
Username: , Password:

 * - Default profile
C1841#
 

In Config Mode:

Chat Script Setup:

When setting up the APN we created separate 3G profiles on the HWIC card. We need config the router to use only one of the profiles. 
In the examples I'm using Telecom's XT APN which is profile 1 which is chat-script gsm "" "ATDT*99#" TIMEOUT 60 "CONNECT"
If you wish to use one of the other profiles to must add the profile number into the chat script as in the examples below:
Profile number 3 = chat-script gsm "" "ATDT*99*3#" TIMEOUT 60 "CONNECT"
Profile number 7 = chat-script gsm "" "ATDT*99*7#" TIMEOUT 60 "CONNECT"
Note: The profile number does not need to be inserted for Profile number 1

 

General Configuration:

The below config is a basic config dump to get the router to connect to 3G to allow internet connectivity through to a PC.
Highlighted in Green is the minimum config requirements to connect to 3G.
  • You will need to implement your own ACL's etc to complete the install securely.
  • It's important to keep the PPP username and password configured on the Cellular0/0/0 Interface even if your APN does not require this. I have used Cisco as the Username and Password as a filler.
  • If you wish to avoid Dial On Demand Routing dropping the connection after a few minutes add dialer idle-timeout 0 to the Cellular0/0/0 Interface to stop this.

C1841#sh run
Building configuration...

Current configuration : 2015 bytes
!
version 12.4
service nagle
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone year
service timestamps log datetime msec localtime show-timezone year
service password-encryption
service sequence-numbers
no service password-recovery
!
hostname C1841
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
logging buffered 2048000
!
no aaa new-model
dot11 syslog
no ip source-route
!
!
ip dhcp excluded-address 192.168.0.1 192.168.0.9
ip dhcp excluded-address 192.168.0.1
!
ip dhcp pool dhcppool
   import all
   network 192.168.0.0 255.255.255.0
   default-router 192.168.0.1
   dns-server 192.168.0.1
   update arp
!
!
ip cef
ip domain name local
no ipv6 cef
!
multilink bundle-name authenticated
!
chat-script gsm "" "ATDT*99#" TIMEOUT 60 "CONNECT"
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 description LAN
 ip address 192.168.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Cellular0/0/0
 description 3G Internet
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer in-band
 dialer string gsm
 dialer-group 1
 async mode interactive
 ppp chap hostname Cisco
 ppp chap password 7 032772382520
 ppp ipcp dns request
 ppp ipcp route default
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Cellular0/0/0
no ip http server
no ip http secure-server
!
!
ip dns server
ip nat inside source list 2 interface Cellular0/0/0 overload
!
access-list 1 remark For Dialer
access-list 1 permit any
access-list 2 remark NAT ACL - Internal LAN Ranges
access-list 2 permit 192.168.0.0 0.0.0.255
dialer-list 1 protocol ip list 1

!
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line 0/0/0
 exec-timeout 0 0
 script dialer gsm
 login
 modem InOut
 no exec
 rxspeed 3600000
 txspeed 384000

line vty 0 4
 login
!
scheduler allocate 20000 1000
end
C1841#
 

Signal Status:

You can quickly identify the signal strength by looking at the RSSI (Receive Signal Strength Indicator) on the HWIC card

Led Status Signal Strength
Solid Green High Signal (-69 dBm or higher)
Fast Green Flash Medium Signal (-89 to -70 dBm)
Slow Green Flash (1sec) Low to medium Signal (-99 to -90 dBm), minimum level for a reliable connection
Off Low Signal (less than -100 dBm)
Solid Amber No service available and no RSSI detected

 

 

 

 

 

 

To view the Receive Signal Strength over different time periods you can check it with the below commends:

C1841#sh cellular 0/0/0 radio history ?
all Show all RSSI history
per-hour Show per hour RSSI history
per-min Show per minute RSSI history
per-sec Show per second RSSI history

C1841#sh cellular 0/0/0 radio history all

C1841 11:37:53 PM Saturday Jan 14 2012 NZDT


888888888888888888888888888888888888888888888888888888888888
555555555555555555555555555555555555555555555555555555555555
140
130
120
110
100
90 ************************************************************
80 ************************************************************
70 ************************************************************
60 ************************************************************
50 ************************************************************
40 ************************************************************
30 ************************************************************
20 ************************************************************
10 ************************************************************
0....5....1....1....2....2....3....3....4....4....5....5....6
0 5 0 5 0 5 0 5 0 5 0
RSSI(-dBm) per second (last 60 seconds)

1
888988818888888888888888888888888888888888888888888888888888
555155502222222222222222222222222222222222222222222222222222
140
130
120
110 *
100 *
90 ########
80 ############################################################
70 ############################################################
60 ############################################################
50 ############################################################
40 ############################################################
30 ############################################################
20 ############################################################
10 ############################################################
0....5....1....1....2....2....3....3....4....4....5....5....6
0 5 0 5 0 5 0 5 0 5 0
RSSI(-dBm) per minute (last 60 minutes)
* = maximum RSSI # = average RSSI

1 11
818811
206600
140
130
120
110 * **
100 * **
90 *****
80 ######
70 ######
60 ######
50 ######
40 ######
30 ######
20 ######
10 ######
0....5....1....1....2....2....3....3....4....4....5....5....6....6....7..
0 5 0 5 0 5 0 5 0 5 0 5 0
RSSI(-dBm) per hour (last 72 hours)
* = maximum RSSI # = average RSSI

 

Diagnostics:

 
Run the show cellular 0/0/0 all command to view all info and config on the HWIC card, in this example profile 1 is active and connected to the 3G network.
 

C1841#sh cellular 0/0/0 all
Hardware Information
====================
Modem Firmware Version = H1_1_9_3MCAP C:/WS/
Modem Firmware built = 12/12/07
Hardware Version = 1.1
International Mobile Subscriber Identity (IMSI) = xxxxxxxxxxxxxxx
International Mobile Equipment Identity (IMEI) = xxxxxxxxxxxxxxx
Factory Serial Number (FSN) = xxxxxxxxxxxxxxx
Modem Status = Online
Current Modem Temperature = 50 deg C, State = Normal

Profile Information
====================
Profile 1 = ACTIVE*
--------
PDP Type = IPv4
PDP address = 122.63.xxx.xxx
Access Point Name (APN) = internet.telecom.co.nz
Authentication = None
Username: , Password:

Profile 2 = INACTIVE
--------
PDP Type = IPv4
Access Point Name (APN) = direct.telecom.co.nz
Authentication = None
Username: , Password:

Profile 3 = INACTIVE
--------
PDP Type = IPv4
Access Point Name (APN) = wapaccess.co.nz
Authentication = None
Username: , Password:

Profile 4 = INACTIVE
--------
PDP Type = IPv4
Access Point Name (APN) = internet
Authentication = None
Username: , Password:

Profile 5 = INACTIVE
--------
PDP Type = IPv4
Access Point Name (APN) = www.vodafone.net.nz
Authentication = None
Username: , Password:

Profile 6 = INACTIVE
--------
PDP Type = IPv4
Access Point Name (APN) = direct.vodafone.net.nz
Authentication = None
Username: , Password:

Profile 7 = INACTIVE
--------
PDP Type = IPv4
Access Point Name (APN) = opt.vodafone.net.nz
Authentication = None
Username: , Password:

 * - Default profile

Data Connection Information
===========================
Data Transmitted = 366096 bytes, Received = 663684 bytes
Profile 1, Packet Session Status = ACTIVE
        IP address = 122.63.xxx.xxx
Profile 2, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 3, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 4, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 5, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 6, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 7, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 8, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 9, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 10, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 11, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 12, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 13, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 14, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 15, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 16, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state

Network Information
===================
Current Service Status = Normal, Service Error = None
Current Service = Combined
Packet Service = HSDPA (Attached)
Packet Session Status = Active
Current Roaming Status = Home
Network Selection Mode = Automatic
Country = NZL, Network = Telecom
Mobile Country Code (MCC) = 530
Mobile Network Code (MNC) = 5
Location Area Code (LAC) = 13305
Routing Area Code (RAC) = 0
Cell ID = 33152
Primary Scrambling Code = 59
PLMN Selection = Automatic
Registered PLMN =  , Abbreviated =
Service Provider = Telecom NZ

Radio Information
=================
Current Band = WCDMA 850, Channel Number = 1062
Current RSSI(RSCP) = -86 dBm
Band Selected = Auto

Modem Security Information
==========================
Card Holder Verification (CHV1) = Disabled
SIM Status = OK
SIM User Operation Required = None
Number of Retries remaining = 3
 

 

Debug Commands:

If you are having any issues you can run the below commends to view the output in the console.

debug dialer
debug chat
debug ppp negotiation
debug ppp error

The below output is where the Cellular0/0/0 Interface has successfully connected.

C1841#
C1841#
000035: *Jan 28 2012 10:23:04.967 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
000036: *Jan 28 2012 10:23:06.503 UTC: Ce0/0/0 DDR: place call
000037: *Jan 28 2012 10:23:06.503 UTC: Ce0/0/0 DDR: Dialing cause ip (s=192.168.0.10, d=192.168.0.1)
000038: *Jan 28 2012 10:23:06.503 UTC: Ce0/0/0 DDR: Attempting to dial gsm
000039: *Jan 28 2012 10:23:06.503 UTC: CHAT0/0/0: Attempting async line dialer script
000040: *Jan 28 2012 10:23:06.503 UTC: CHAT0/0/0: Dialing using Modem script: gsm & System script: none
000041: *Jan 28 2012 10:23:06.511 UTC: CHAT0/0/0: process started
000042: *Jan 28 2012 10:23:06.511 UTC: CHAT0/0/0: Asserting DTR
000043: *Jan 28 2012 10:23:06.511 UTC: CHAT0/0/0: Chat script gsm started
000044: *Jan 28 2012 10:23:06.511 UTC: CHAT0/0/0: Sending string: ATDT*99#
000045: *Jan 28 2012 10:23:06.511 UTC: CHAT0/0/0: Expecting string: CONNECT
000046: *Jan 28 2012 10:23:06.555 UTC: CHAT0/0/0: Completed match for expect: CONNECT
000047: *Jan 28 2012 10:23:06.555 UTC: CHAT0/0/0: Chat script gsm finished, status = Success
000048: *Jan 28 2012 10:23:08.691 UTC: %LINK-3-UPDOWN: Interface Cellular0/0/0, changed state to up
000049: *Jan 28 2012 10:23:08.691 UTC: Ce0/0/0 DDR: Dialer statechange to up
000050: *Jan 28 2012 10:23:08.691 UTC: Ce0/0/0 DDR: Dialer call has been placed
000051: *Jan 28 2012 10:23:08.691 UTC: Ce0/0/0 PPP: Using dialer call direction
000052: *Jan 28 2012 10:23:08.691 UTC: Ce0/0/0 PPP: Treating connection as a callout
000053: *Jan 28 2012 10:23:08.691 UTC: Ce0/0/0 PPP: Session handle[8A000004] Session id[2]
000054: *Jan 28 2012 10:23:08.691 UTC: Ce0/0/0 PPP: Phase is ESTABLISHING, Active Open
000055: *Jan 28 2012 10:23:08.691 UTC: Ce0/0/0 PPP: No remote authentication for call-out
000056: *Jan 28 2012 10:23:08.691 UTC: Ce0/0/0 LCP: O CONFREQ [Closed] id 3 len 20
000057: *Jan 28 2012 10:23:08.691 UTC: Ce0/0/0 LCP:    ACCM 0x000A0000 (0x0206000A0000)
000058: *Jan 28 2012 10:23:08.691 UTC: Ce0/0/0 LCP:    MagicNumber 0x12AB4D95 (0x050612AB4D95)
000059: *Jan 28 2012 10:23:08.695 UTC: Ce0/0/0 LCP:    PFC (0x0702)
000060: *Jan 28 2012 10:23:08.695 UTC: Ce0/0/0 LCP:    ACFC (0x0802)
000061: *Jan 28 2012 10:23:08.695 UTC: Ce0/0/0 LCP: I CONFREQ [REQsent] id 2 len 25
000062: *Jan 28 2012 10:23:08.699 UTC: Ce0/0/0 LCP:    ACCM 0x00000000 (0x020600000000)
000063: *Jan 28 2012 10:23:08.699 UTC: Ce0/0/0 LCP:    AuthProto CHAP (0x0305C22305)
000064: *Jan 28 2012 10:23:08.699 UTC: Ce0/0/0 LCP:    MagicNumber 0x966D4493 (0x0506966D4493)
000065: *Jan 28 2012 10:23:08.699 UTC: Ce0/0/0 LCP:    PFC (0x0702)
000066: *Jan 28 2012 10:23:08.699 UTC: Ce0/0/0 LCP:    ACFC (0x0802)
000067: *Jan 28 2012 10:23:08.699 UTC: Ce0/0/0 LCP: O CONFACK [REQsent] id 2 len 25
000068: *Jan 28 2012 10:23:08.699 UTC: Ce0/0/0 LCP:    ACCM 0x00000000 (0x020600000000)
000069: *Jan 28 2012 10:23:08.699 UTC: Ce0/0/0 LCP:    AuthProto CHAP (0x0305C22305)
000070: *Jan 28 2012 10:23:08.699 UTC: Ce0/0/0 LCP:    MagicNumber 0x966D4493 (0x0506966D4493)
000071: *Jan 28 2012 10:23:08.699 UTC: Ce0/0/0 LCP:    PFC (0x0702)
000072: *Jan 28 2012 10:23:08.699 UTC: Ce0/0/0 LCP:    ACFC (0x0802)
000073: *Jan 28 2012 10:23:08.699 UTC: Ce0/0/0 LCP: I CONFACK [ACKsent] id 3 len 20
000074: *Jan 28 2012 10:23:08.699 UTC: Ce0/0/0 LCP:    ACCM 0x000A0000 (0x0206000A0000)
000075: *Jan 28 2012 10:23:08.699 UTC: Ce0/0/0 LCP:    MagicNumber 0x12AB4D95 (0x050612AB4D95)
000076: *Jan 28 2012 10:23:08.699 UTC: Ce0/0/0 LCP:    PFC (0x0702)
000077: *Jan 28 2012 10:23:08.699 UTC: Ce0/0/0 LCP:    ACFC (0x0802)
000078: *Jan 28 2012 10:23:08.699 UTC: Ce0/0/0 LCP: State is Open
000079: *Jan 28 2012 10:23:08.699 UTC: Ce0/0/0 PPP: Phase is AUTHENTICATING, by the peer
000080: *Jan 28 2012 10:23:08.703 UTC: Ce0/0/0 CHAP: I CHALLENGE id 1 len 35 from "UMTS_CHAP_SRVR"
000081: *Jan 28 2012 10:23:08.703 UTC: Ce0/0/0 CHAP: Using hostname from interface CHAP
000082: *Jan 28 2012 10:23:08.703 UTC: Ce0/0/0 CHAP: Using password from interface CHAP
000083: *Jan 28 2012 10:23:08.703 UTC: Ce0/0/0 CHAP: O RESPONSE id 1 len 26 from "Cisco"
000084: *Jan 28 2012 10:23:08.711 UTC: Ce0/0/0 CHAP: I SUCCESS id 1 len 4
000085: *Jan 28 2012 10:23:08.711 UTC: Ce0/0/0 PPP: Phase is FORWARDING, Attempting Forward
000086: *Jan 28 2012 10:23:08.711 UTC: Ce0/0/0 PPP: Phase is ESTABLISHING, Finish LCP
000087: *Jan 28 2012 10:23:08.711 UTC: Ce0/0/0 PPP: Phase is UP
000088: *Jan 28 2012 10:23:08.711 UTC: Ce0/0/0 IPCP: O CONFREQ [Closed] id 1 len 22
000089: *Jan 28 2012 10:23:08.711 UTC: Ce0/0/0 IPCP:    Address 0.0.0.0 (0x030600000000)
000090: *Jan 28 2012 10:23:08.715 UTC: Ce0/0/0 IPCP:    PrimaryDNS 0.0.0.0 (0x810600000000)
000091: *Jan 28 2012 10:23:08.715 UTC: Ce0/0/0 IPCP:    SecondaryDNS 0.0.0.0 (0x830600000000)
000092: *Jan 28 2012 10:23:08.715 UTC: Ce0/0/0 PPP: Process pending ncp packets
000093: *Jan 28 2012 10:23:09.719 UTC: Ce0/0/0 IPCP: I CONFNAK [REQsent] id 1 len 16
000094: *Jan 28 2012 10:23:09.719 UTC: Ce0/0/0 IPCP:    PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
000095: *Jan 28 2012 10:23:09.719 UTC: Ce0/0/0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
000096: *Jan 28 2012 10:23:09.719 UTC: Ce0/0/0 IPCP: O CONFREQ [REQsent] id 2 len 22
000097: *Jan 28 2012 10:23:09.719 UTC: Ce0/0/0 IPCP:    Address 0.0.0.0 (0x030600000000)
000098: *Jan 28 2012 10:23:09.719 UTC: Ce0/0/0 IPCP:    PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
000099: *Jan 28 2012 10:23:09.719 UTC: Ce0/0/0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
000100: *Jan 28 2012 10:23:10.723 UTC: Ce0/0/0 IPCP: I CONFNAK [REQsent] id 2 len 16
000101: *Jan 28 2012 10:23:10.723 UTC: Ce0/0/0 IPCP:    PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
000102: *Jan 28 2012 10:23:10.723 UTC: Ce0/0/0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
000103: *Jan 28 2012 10:23:10.723 UTC: Ce0/0/0 IPCP: O CONFREQ [REQsent] id 3 len 22
000104: *Jan 28 2012 10:23:10.723 UTC: Ce0/0/0 IPCP:    Address 0.0.0.0 (0x030600000000)
000105: *Jan 28 2012 10:23:10.723 UTC: Ce0/0/0 IPCP:    PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
000106: *Jan 28 2012 10:23:10.723 UTC: Ce0/0/0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
000107: *Jan 28 2012 10:23:11.411 UTC: Ce0/0/0 IPCP: I CONFREQ [REQsent] id 1 len 4
000108: *Jan 28 2012 10:23:11.411 UTC: Ce0/0/0 IPCP: O CONFACK [REQsent] id 1 len 4
000109: *Jan 28 2012 10:23:11.415 UTC: Ce0/0/0 IPCP: I CONFNAK [ACKsent] id 3 len 22
000110: *Jan 28 2012 10:23:11.415 UTC: Ce0/0/0 IPCP:    Address 122.63.xxx.xxx (0x03067A3F5495)
000111: *Jan 28 2012 10:23:11.415 UTC: Ce0/0/0 IPCP:    PrimaryDNS 202.27.156.72 (0x8106CA1B9C48)
000112: *Jan 28 2012 10:23:11.415 UTC: Ce0/0/0 IPCP:    SecondaryDNS 202.27.158.40 (0x8306CA1B9E28)
000113: *Jan 28 2012 10:23:11.415 UTC: Ce0/0/0 IPCP: O CONFREQ [ACKsent] id 4 len 22
000114: *Jan 28 2012 10:23:11.415 UTC: Ce0/0/0 IPCP:    Address 122.63.xxx.xxx (0x03067A3F5495)
000115: *Jan 28 2012 10:23:11.415 UTC: Ce0/0/0 IPCP:    PrimaryDNS 202.27.156.72 (0x8106CA1B9C48)
000116: *Jan 28 2012 10:23:11.415 UTC: Ce0/0/0 IPCP:    SecondaryDNS 202.27.158.40 (0x8306CA1B9E28)
000117: *Jan 28 2012 10:23:11.415 UTC: Ce0/0/0 IPCP: I CONFACK [ACKsent] id 4 len 22
000118: *Jan 28 2012 10:23:11.415 UTC: Ce0/0/0 IPCP:    Address 122.63.xxx.xxx (0x03067A3F5495)
000119: *Jan 28 2012 10:23:11.415 UTC: Ce0/0/0 IPCP:    PrimaryDNS 202.27.156.72 (0x8106CA1B9C48)
000120: *Jan 28 2012 10:23:11.415 UTC: Ce0/0/0 IPCP:    SecondaryDNS 202.27.158.40 (0x8306CA1B9E28)
000121: *Jan 28 2012 10:23:11.415 UTC: Ce0/0/0 IPCP: State is Open
000122: *Jan 28 2012 10:23:11.419 UTC: Ce0/0/0 IPCP: Install negotiated IP interface address 122.63.xxx.xxx
000123: *Jan 28 2012 10:23:11.463 UTC: Ce0/0/0 DDR: dialer protocol up
C1841#

Dissconnecting due to lack of traffic.
C1841#
000125: *Jan 28 2012 10:47:58.359 UTC: Ce0/0/0 DDR: idle timeout
000126: *Jan 28 2012 10:47:58.359 UTC: Ce0/0/0 PPP: Sending Acct Event[Down] id[5]
000127: *Jan 28 2012 10:47:58.359 UTC: Ce0/0/0 IPCP: State is Closed
000128: *Jan 28 2012 10:47:58.359 UTC: Ce0/0/0 PPP: Phase is TERMINATING
000129: *Jan 28 2012 10:47:58.359 UTC: Ce0/0/0 LCP: O TERMREQ [Open] id 4 len 4
000130: *Jan 28 2012 10:47:58.375 UTC: Ce0/0/0 LCP: I TERMACK [TERMsent] id 4 len 4
000131: *Jan 28 2012 10:47:58.375 UTC: Ce0/0/0 LCP: State is Closed
000132: *Jan 28 2012 10:47:58.375 UTC: Ce0/0/0 PPP: Phase is DOWN
000133: *Jan 28 2012 10:47:58.379 UTC: Ce0/0/0 DDR: disconnecting call
000134: *Jan 28 2012 10:48:00.375 UTC: %LINK-5-CHANGED: Interface Cellular0/0/0, changed state to reset
000135: *Jan 28 2012 10:48:05.511 UTC: %LINK-3-UPDOWN: Interface Cellular0/0/0, changed state to down
000136: *Jan 28 2012 10:48:15.375 UTC: Ce0/0/0 DDR: re-enable timeout
C1841#